[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ldapdb broken with sasl-2.1.19?

On Tue, 10 Aug 2004, paul k wrote:


I can't get ldapdb plugin to work with sasl-2.1.19. It compiles fine and the resulting libldapdb.so.2.1.19 looks sane. The error on slapd startup is:

Aug 10 21:54:41 holzkopp slapd[26013]: auxpropfunc error invalid parameter supplied
Aug 10 21:54:41 holzkopp slapd[26013]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: ldapdb

This error can be ignored unless you explicitly specified ldapdb as an auxprop plugin for slapd. slapd uses its own internal auxprop plugin.

holzkopp lorikeet-heimdal # ldd /usr/lib/sasl2/libldapdb.so.2
       libldap-2.2.so.7 => /usr/lib/libldap-2.2.so.7 (0x4000a000)
       liblber-2.2.so.7 => /usr/lib/liblber-2.2.so.7 (0x40044000)
       libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40051000)
       libresolv.so.2 => /lib/libresolv.so.2 (0x4014f000)
       libc.so.6 => /lib/libc.so.6 (0x40161000)
       libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x40290000)
       libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x402a7000)
       libdl.so.2 => /lib/libdl.so.2 (0x402d8000)
       /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

platform is linux 2.4.25, db-4.2+patches, openldap-2.2.15, heimdal-0.6.2. Any ideas how to track this down further?

How do you know the plugin is not working? Have you tested the plugin with the sample client and server software that comes with cyrus-sasl ($cyrus-sasl-src/sample)?