[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: OpenLDAP in Tru64 UNIX

I assume "version 2" is not referring to a LDAP version but an
LDIF version.  Some older versions of OpenLDAP used a bogus
"version: 2" of LDIF (which differs from the current LDIFv2
proposal).  Both OpenLDAP 2.0 and 2.1 support and, IIRC,
use LDAPv3 by default.  I don't "allow bind_v2" matters here
one bit.

BTW, when you say "no results" do you noSuchObject or do
you mean success with no entries.

Regardless, I suggest you check the server logs for details
as to why its returning what its returning (or not returning
in this case).

Beyond that, I suggest you consider upgrading the 2.0
system to a current version.


At 01:36 PM 6/7/2004, Alessandro Kenji Urakawa wrote:
>Hi Jorge,
>Try to put the parameter -b <baseDN> in the ldapsearch, and allow bind_v2 in the slapd.conf (slackware).
>Alessandro Kenji Urakawa
>Jorge Ruão wrote:
>>I'm running OpenLDAP 2.0.27 in a Tru64 Unix v5.1b operating
>>system (the one that comes with Tru64 unix). The LDAP Module for system authentication (Tru64 UNIX) is also installed to allow the local services (SSL, TELNET, FTP and LOGIN) to use LDAP accounts.
>>I'm also runnig Openldap 2.1.30 in a Slackware 9.1 distribution.
>>Everything goes fines except when I try to "ldapsearch" from Tru64 UNIX to Slackware.
>>When i run ldapsearch from the Tru64 Unix machine (ldapsearch -H ldap://heaven.fe.up.pt -D cn=admin,dc=fe,dc=up,dc=pt -W -x) to the Slackware machine, i'm getting no results!
>>Ldapsearch from Slackware Machine to Slackware OpenLDAP server (gives all results)
>>Ldapsearch from Slackware Machine to Tru64 UNIX OpenLDAP server  
>>(gives all results)
>>Ldapsearch from Tru64 UNIX Machine to Tru64 UNIX OpenLDAP server  
>>(gives all results)
>>Ldapsearch from Tru64 UNIX Machine to Slackware OpenLDAP server  
>>(gives NO results)
>>In the ldapsearch from Tru64 UNIX i see a message saying "version 2", i believe that it is using LDAP v2. But this shouldn't be a problem since OpenLDAP 2.1.30 in Slackware is not runing with "Require LDAPv3" option.
>>Can anyone give me a hint here?Or point me to where should i search?
>>Jorge Ruão