[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAP library version number

Quanah Gibson-Mount wrote:

--On Thursday, March 04, 2004 4:19 PM +0100 "jehan.procaccia" <jehan.procaccia@int-evry.fr> wrote:

I noticed that openldap 2.2.6 provides : $ rpm -qpli openldap-2.2.6-1.i386.rpm | grep liblber /usr/lib/liblber.so.199 /usr/lib/liblber.so.199.3.4

Library versioning is incorrect in 2.2.6 and prior. Kurt posted yesterday to the devel list that it will be fixed in the 2.2.7 release.


OK so I've just compiled 2.2.7 and got a similar problem :-(
libs are named this way; "liblber-2.2.7.so" and installed RH packages expect something in this way; "liblber.so.2"
Maybe I can manage in spec and Makefile to get to that point, but is it up to users to change that or the mainstream distribution should take care of this naming convention? that just a question don't take it badly ;-)

Here's my modifications on my openldap-2.2.7.spec file
* Thu Mar 25 2004 Jehan Procaccia <jehan.procaccia@int-evry.fr> 2.2.7-1
- upgraded to openldap 2.2.7
- added patch5 openldap-2.2.7-slapdmakefile.patch regarding "Symlink points to BuildRoot" rpm error, cf http://www.ale.org/archive/ale/ale-2002-03/msg00012.html- modified in %files section lib*.so.* to lib*.so
- requires cyrus-sasl-2.1.15
- requires krb5-config from krb5-devel which is in /usr/kerberos/bin/ , export your PATH !

Here's what happens :

$ rpm -qpli openldap-2.2.7-1.i386.rpm | grep liblber*

$ rpm -qpli openldap-2.2.7-1.i386.rpm | grep libldap*

[root@corbeau /usr/src/redhat/RPMS/i386]
$ rpm -Uvh *2.2.7-1*.rpm
error: Failed dependencies:
       liblber.so.2 is needed by (installed) gnomemeeting-0.96.0-4
       liblber.so.2 is needed by (installed) php-ldap-4.2.2-18.3
       liblber.so.2 is needed by (installed) autofs-3.1.7-36
       liblber.so.2 is needed by (installed) postfix-2.0.11-5
       liblber.so.2 is needed by (installed) nss_ldap-202-5
       liblber.so.2 is needed by (installed) evolution-1.2.2-5
       liblber.so.2 is needed by (installed) kdelibs-3.1-11
       liblber.so.2 is needed by (installed) apr-util-0.9.3-10
       liblber.so.2 is needed by (installed) libuser-0.51.7-1
       liblber.so.2 is needed by (installed) squid-2.5.STABLE1-2
       libldap.so.2 is needed by (installed) gnomemeeting-0.96.0-4
       libldap.so.2 is needed by (installed) gnupg-1.2.1-3
       libldap.so.2 is needed by (installed) php-ldap-4.2.2-18.3
       libldap.so.2 is needed by (installed) autofs-3.1.7-36
etc ...

Thanks for your advices .

Quanah Gibson-Mount
Principal Software Developer
ITSS/TSS/Computing Systems
ITSS/TSS/Infrastructure Operations
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html