[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem with web based apps

It is openldap-2.0.21.  I will give the U Michigan list a try, thanks.

Quanah Gibson-Mount wrote:


You do not specify what LDAP server you are using. This also sounds like a general LDAP question, not a question about OpenLDAP software itself. You might want to try the U Michigan LDAP list:



--On Thursday, March 18, 2004 1:12 PM -0600 "B. J. Zolp" <bjz@dewittross.net> wrote:

Hello, my firm has several ldap servers for managing contact and
employee info. These ldap databases are accessed via two php based web
front ends written by a former employee. Recently I have had to replace
the two servers that these web based front ends run on. Although I am
fairly familiar with ldap, I have similar issues with both replacements...

1. In replacing the first server I decided to do a fresh install of
the latest Redhat to bring it up to date from the old Redhat 6.x that was
on the old box. With this machine the front end and the ldap server are
actually on the same box so after successfully importing the ldif from
the old server I moved the php code to the appropriate directory and gave
it a try. The php executes fine, but when accessing anything from the
ldap database it will fail saying it is unable to access the ldap
database (checked logs for both apache and ldap server and found no
errors). However, when I simply execute this code while the old server
is up and on the network it will access the ldap DB from it just fine,
but when I take the old one down and switch hostname and IP to make the
new machine similar to the old, it gives me the access problem.

I also tried simply copying the old DB over without doing an import
of an ldif with similar results. Additionally, I did a fresh install of
the same redhat version that is on the old server with similar version of
ldap, php, and apache. This also had similar unwanted results. Only
when I did a direct dd copy of the old machine to the new one did I get a
new working system. So I managed to get this working well enough, but
these issues lead me to my second current problem, which is more
important. I thought I would include this first account of my experiences
in order to perhaps help other readers gain any insight as to what I am
doing wrong or perhaps overlooking.

2. This current server replacement is different from the first in that
the ldap DB is not local and is left untouched in the upgrade of this
server. The server I am replacing is basically a straight up web server
that accesses the external ldap server with one php web application for
employee data. I started with a fresh current distro install and moved
the www documents and php over to the new box. After configuring the
machine with the same ip/hostname as the box it is replacing I hooked it
to the network and tested it out. All webpages and php code is served up
fine, but I get a similar problem where it cannot access the ldap server
whenever I attempt to lookup data. I know that the machine can access
the ldap server via hostname/IP over ping and other network apps. So I
am at a loss as to what is causing this problem.
Long story short: what do I have to do to be able to drag a php web app
over to a new box and get it to run on there?

Any help or questions for clarification would be great.


B. J. Zolp

Quanah Gibson-Mount
Principal Software Developer
ITSS/TSS/Computing Systems
ITSS/TSS/Infrastructure Operations
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html