[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Upgrade steps from 2.1.x to 2.2.x

--On Monday, March 15, 2004 4:10 PM -0800 Jeff Leung <jeffleung@mac.com> wrote:


Is there anything special that I will need to do to upgrade from OpenLDAP
2.1.26 to 2.2.x? Specificially,

1. Will it be necessary to use slapcat/slapadd, or can I use my existing
database files (I am currently using BerkeleyDB 4.2.52-2).

You must slapcat/slapadd. The underlying DB format changed between 2.1.26 and 2.2.x. I suggest using 2.2.6 or later.

You also may want to rebuild your entryCSN pieces by stripping them from the DB dump, and then releoading. If you later want to use syncrepl (currently not functional), you will need the new entryCSN format.


Quanah Gibson-Mount
Principal Software Developer
ITSS/TSS/Computing Systems
ITSS/TSS/Infrastructure Operations
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html