[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: ldaps vs -ZZ

change your port to 389 (or what ever your default port is for normal

-----Original Message-----
From: Adam Gautier [mailto:adam_gautier@yahoo.com]
Sent: Wednesday, February 11, 2004 4:30 PM
To: openldap-software@OpenLDAP.org
Subject: ldaps vs -ZZ

Why does 'ldapsearch -x -H ldaps://myserver.com "cn=*"' work but 
'ldapsearch -x -h myserver.com -p 636 "cn=*" -ZZ' fails.  Both are using
TLS but the second one returns:

%> ldapsearch -x -h myserver.com -p 636 "cn=*" -ZZ
ldap_bind: Can't contact LDAP server (81)

TLS trace: SSL_accept:before/accept initialization
tls_read: want=11, got=11
  0000:  30 0c 02 01 01 60 07 02  01 03 04                  0....`.....
TLS trace: SSL_accept:error in SSLv2/v3 read client hello A
TLS: can't accept.
TLS: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
connection_read(7): TLS accept error error=-1 id=0, closing
connection_closing: readying conn=0 sd=7 for close
connection_close: conn=0 sd=7

Any help would be great and I  can provide more info if needed.  I have 
search message archives about this to no avail. Any help would be great 
and greatly appreciated, Thanks.

NOTICE: This E-mail may contain confidential information. If you are not
the addressee or the intended recipient please do not read this E-mail
and please immediately delete this e-mail message and any attachments
from your workstation or network mail system. If you are the addressee
or the intended recipient and you save or print a copy of this E-mail,
please place it in an appropriate file, depending on whether
confidential information is contained in the message.