[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: v2.1.xx and autofs (bind errors).

> hi,
> I'm  trying to get autofs working w/ OpenLDAP 2.1.21.
> If I add allow bind_v3 I get an authentication error:

I believe that openldap 2.1 uses bind_v3 by default.  Shouldn't you have
allow bind_v2 in slapd.conf?

>  RESULT tag=97 err=53 text=unauthenticated bind (DN with no password) disallowed
> and if I add allow bind_anon_cred I get a protocol error:
> RESULT tag=97 err=2 text=requested protocol version not allowed

It sounds like autofs is trying to bind with v2, but you don't have allow
bind_v2 in slapd.conf.  But if it was just a typo above, then I'm no help,
never tried it.

> Any ideas.  This problem exists w/ both Debian woody and Redhat clients
> using autofs.  The server works fine.
> Thanks,
> j.
> --
> ......................
> ..... Jason C. Leach
> ..
> Current PGP/GPG Key ID: 43AD2024