[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Compile Issues on AIX 5.1

Title: RE: Compile Issues on AIX 5.1

> I have had success recently with configuring, compiling,
> linking, and executing
> OpenLDAP 2.1 on AIX 4.3.3, but have not been so lucky with
> AIX 5.2.0, where the
> configure step fails to find the Berkeley DB libraries.
> Given that I am able to compile and link in AIX 4.3.3, I felt
> that a similar
> strategy would be acceptable for AIX 5.2, but so far, no luck...

I've used the following after a tip from Piotr Rybok: (It's a single line)

env CC="gcc" CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib"  ./configure --with-tls

BTW if the libs aren't in /usr/local/lib but in /usr/local/ssl/lib/openssl then specify this directory (and the same for the berkley db)

And I've used gnu make to get the install correctly. (also a tip from Piotr) It works like a charm overhere on AIX 5.1. I suspect that aix 5.2 will need the same approach.

The biggest problem now is getting linux and AIX to use the directory in the same way or get de OpenLDAP server to act like an idiot (not case sensitive).

J. Huijsmans

Rabobank ICT
Serverbedrijf Unix

... Doing it right is no excuse for not meeting the deadline

De informatie opgenomen in dit bericht kan vertrouwelijk zijn en
is uitsluitend bestemd voor de geadresseerde. Indien u dit bericht
onterecht ontvangt, wordt u verzocht de inhoud niet te gebruiken en
de afzender direct te informeren door het bericht te retourneren.
The information contained in this message may be confidential
and is intended to be exclusively for the addressee. Should you
receive this message unintentionally, please do not use the contents
herein and notify the sender immediately by return e-mail.