[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Segmentation fault on 2.1.13

Jehan PROCACCIA wrote:
Michael Ströder wrote:
Simon Gao wrote:

I still got segmentation fault even without any index. This is really wired. Have you tried 2.1.13 with your current slapd.conf yet?

Any chance you have a Berkeley-DB library mix on your system? Check your RPM-list.

Indeed that is my case, with RH 8.0 we have db4-4.0.14-14 , but I did compile statically to DB 4.1.25 using CPFALGS and LDFLAGS. It used to work fine when I compiled 2.1.12 the same way !? What can be wrong ? A miscompilation of me or a real problem with 2.1.13 ?

I did not succeed either on SuSE Linux 8.1. Same situation here: I can't remove the db-4.0.14 package since a lot of other packages rely on it. Especially the SASL and Kerberos stuff uses the package db.

I have no clue how to work around that.

Ciao, Michael.