[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: SASL Bind vs. PHP Bind

I already did both "allow bind_v2" and used that function to
set version. Didn't worked.

Chris Maxwell wrote:
On Fri, 2003-02-21 at 08:34, Herbert G. Fischer wrote:


I forgot to mention that I've tryed with and without this piece
of string with no success.

Mike O'Rourke wrote:

"Herbert G. Fischer" <hgfischer@trama.com> 02/20/03 11:13pm >>>

Hi again,

I'm using Postfix+SASL+OpenLDAP to do SMTPd autentication for users,
and it's working very well.

Since you didn't indicate which version of OpenLDAP you were using, nor
whether you have "allow bind_v2" enabled,

try doing this right after your ldap_connect();

	ldap_set_option($resid, LDAP_OPT_PROTOCOL_VERSION, 3)

as that is one of the more common errors when using PHP, which defaults
to using LDAPv2.