[Date Prev][Date Next] [Chronological] [Thread] [Top]

ldap_init_getfilter/etc removed in 2.1.x?

I'm trying to compile the old Web-to-LDAP frontend, web500gw
against OpenLDAP 2.1.12.  But the compile dies very quickly
because LDAPFiltDesc is no longer defined.

In fact, it looks like all support for ldapfilters.conf
and ldaptemplates has been removed between 2.0.23 and 2.1.12.

So, what do I do?  Is there some other separate package that
now provides these functions, or this functionality?  Or do 
I need to either:

   o  Hack up an older OpenLDAP to create "compatibility" 
      libs for older apps?  Which could get messy, since
      you didn't change the libldap major version when you
      removed these functions.

   o  Copy libldap/getfilter.c, etc from an old OpenLDAP and 
      compile them directly into web500gw?