[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Openldap 2.1.3 and freeradius 0.7

Christian W Pohl writes:

Hi list,

I try to get freeradius to work with openldap 2.1.3

I get an error when the radius-server connects to the ldap: "requested protocol version not allowed"
What does this message mean? can I configure something in openldap or must I look in the freeradius-config?

Sounds like freeradius is attempting a LDAPv2 bind, which is disabled
by default in 2.1 (LDAPv2 is historical). You may use "allow bind_v2"
in slapd.conf to re-enable it, or play with freeradius internals to
set protocol version to LDAPv3 before binding.


Dr. Pierangelo Masarati | voice: +39 02 2399 8309
Dip. Ing. Aerospaziale | fax: +39 02 2399 8334
Politecnico di Milano | mailto:pierangelo.masarati@polimi.it
via La Masa 34, 20156 Milano, Italy | http://www.aero.polimi.it/~masarati