[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Berkeley DB 4.0.14 and openldap 2.1.3

On Fri, Jul 12, 2002 at 11:15:14AM -0600, BaTien Duong wrote:
> I try to configure openldap 2.1.3 with Berkeley DB 4.0.14 and get BerkeleyDB
> version incompatible. Helps are apprciated:

>     error: BerkeleyDB version incompatible
>     I search for header places and found they are in srcdir /include and
> /usr/include/db1 and /usr/include/db2. Do I need to specify CPPFLAGS and
> LDFLAGS. Experts of OpenLdap installers please help.

I have just run into a very similar problem building 2.1.3 on FreeBSD
4.6-STABLE. It seems that the 'configure' script does not take note of
its own --includedir flag when testing the db libraries so if your
include files and libs are not in places the compiler looks by default
you will get this error.

Setting CPPFLAGS and LDFLAGS should solve the problem, but I think
some improvements to configure might be called for too.

I used:

export CPPFLAGS="-I/usr/local/include -I/usr/local/include/db4"
export LDFLAGS=-L/usr/local/lib
./configure     --prefix=/usr/local \
                --includedir=/usr/local/include/db4 \
                --enable-spasswd \
                --enable-aci \
                --enable-rewrite \
                --enable-dnssrv \
                --enable-ldap \
                --enable-meta \
                --enable-monitor \
                --enable-null \
                --enable-perl \

|                 From Andrew Findlay, Skills 1st Ltd                 |
| Consultant in large-scale systems, networks, and directory services |
|        Andrew.Findlay@skills-1st.co.uk       +44 1628 782565        |