[Date Prev][Date Next] [Chronological] [Thread] [Top]

problem with searching on objectclass=bankDepartment


I think I have a problem with searching on index objectclass. 

When I try to search with base "bankCode=3271,ou=LB,o=Rabobank,c=NL" with
filter "objectClass=bankDepartment"  no results are returned. 
When I try to search on a different location, for example
"bankCode=3269,.....", some entries are returned.

BankCode 3271 DOES contain an object with objectClass=bankDepartment.

Reindexing the database with slapindex does not solve the problem (I also
removed the index-files before running slapindex); but after I modify the
entry with a browser (changing the cn for example), the search DOES find the
entry, so the modify solves the problem.

I think the problem is a slapindex problem; the database was reindexed
before the error occured.

I'm using Openldap version 2.0.18 and berkeley DB version 3.2.9.

Any Idea?



Gerrit van den Hul
Senior Software Designer
Altium - Think it, Design it, Build it
Phone Rabobank: +31 30 21 51 390
Phone Altium: +31 33 455 8584
Fax Altium: +31 33 455 5503
mobile: +31 6 1464 9859
E-Mail Rabobank: G.Hul@rf.rabobank.nl
E-Mail Altium: gerrit.van.den.hul@altium.nl
Private E-mail: G.vandenHul@inter.nl.net
URL: http://www.altium.com

De informatie opgenomen in dit bericht kan vertrouwelijk zijn en 
is uitsluitend bestemd voor de geadresseerde. Indien u dit bericht 
onterecht ontvangt, wordt u verzocht de inhoud niet te gebruiken en 
de afzender direct te informeren door het bericht te retourneren. 
The information contained in this message may be confidential 
and is intended to be exclusively for the addressee. Should you 
receive this message unintentionally, please do not use the contents 
herein and notify the sender immediately by return e-mail.