[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ERROR - openldap with Berkeley DB 3.3.11

> Hi All,
> When i complile opneldap2.0,11 with Berkeley DB 3.3.11(latest) on Redhat linux
> 6.2 system , i get the following error

There have already been postings on the subject. The API of SleepyCat 
changed with version 3.3.11; the way memory allocation routines are
registered is now different and there's no backwards compatibility.
As a result, the old db handling code is broken and needs to be fixed.
You will not be able to use 3.3.11 until the next release of OpenLDAP
(hopefully), or you'll have to recode the interface yourself.