[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: autofs and OpenLDAP integration

The problem is you're specifying *way* wrong stuff in your LDIF:

# This entry causes autofs to start up another automounter on /mci/mci.
dn: cn=mci,ou=auto.mci,dc=int-evry,dc=fr
objectClass: top
objectClass: automount
description: mci home directories
cn: mci
automountInformation: -fstype=autofs

WTF? That last line should be:

automountInformation: -fstype=autofs

However, see my other email - you just need to make the homdirectory be
"/mci/proccaci" or else approriately rename the LDAP OU's - I personally
wouldn't mess about with this recursive autofs stuff, although I didn't know
you could do it - cheers for the tip Nalin!


| Phil Mayers, Network Support     | 
| Centre for Computing Services    | 
| Imperial College                 | 

-----Original Message-----
From: Nalin Dahyabhai [mailto:nalin@redhat.com]
Sent: 20 July 2001 19:24
Cc: openldap-software@OpenLDAP.org
Subject: Re: autofs and OpenLDAP integration

On Fri, Jul 20, 2001 at 06:25:30PM +0200, Jehan PROCACCIA wrote:
> $/etc/init.d/autofs status
> Configured Mount Points:
> ------------------------
> /usr/sbin/automount /mci ldap
> openldap.int-evry.fr:ou=auto.mci,dc=int-evry,dc=fr
> Active Mount Points:
> --------------------
> /usr/sbin/automount /mci ldap
> openldap.int-evry.fr:ou=auto.mci,dc=int-evry,dc=fr
> It seems to work better but now it is looking for a library that is not
> present ?
> automount[24668]: cannot open lookup module
> openldap (/usr/lib/autofs//lookup_openldap.so: cannot open shared object
> file: No such file or directory)
> where should it come from ?

Whoa, that's freaky.  It should be using /usr/lib/autofs/lookup_ldap.so
for looking up entries using LDAP.

> Jul 20 13:30:14 openldap automount[24663]: mount(autofs): failed to
> mount openldap:ou=auto.mci.mci,dc=int-evry,dc=fr on /mci/mci
> Jul 20 13:30:14 openldap automount[24602]: attempting to mount entry
> /mci/mci
> Jul 20 13:30:14 openldap automount[24668]: starting automounter version
> 3.1.7, path = /mci/mci, maptype = openldap, mapname =
> ou=auto.mci.mci,dc=int-evry,dc=fr
> Jul 20 13:30:14 openldap automount[24668]: cannot open lookup module
> openldap (/usr/lib/autofs//lookup_openldap.so: cannot open shared object
> file: No such file or directory)

That's very strange.  Autofs is somehow determining that the map type is
"openldap" instead of "ldap", which is wrong.  It then uses the map type
to construct the path for the lookup module to use ("yp" maps are looked
up using lookup_yp.so, "nisplus" maps using lookup_nisplus.so, and so on).

Off-hand, a workaround would be to symlink lookup_openldap.so to
lookup_ldap.so in /usr/lib/autofs, but I'm stumped as to where it's
getting the wrong map type passed in, since the script is reporting the
right configuration setup.