[Date Prev][Date Next] [Chronological] [Thread] [Top]

LinuxThreads and OpenLDAP 2.0.7?

I've looked everywhere for a definitive answer to this question, but
there isn't one:

Is OpenLDAP safe with LinuxThreads?

I remember reading that 1.2.x was not safe with preemptive threads (such
as LinuxThreads).  There was talk that 2.0.x would be OK with it, but I
have never found any confirmation.

I've looked at several 2.0.7 SRPMS but they all --disable-threads for
slapd, so I'm assuming it is still not safe.

BTW: I'm running RH 6.2 with glibc-2.1.3-22 and db3-3.1.17-4.6x from
the SRPM.

Carl Litt
Network Administrator
Execulink Internet