[Date Prev][Date Next] [Chronological] [Thread] [Top]

Can't conntact LDAP server


I'm having difficulties as I try to install the OpenLDAP. I followed the
instructions in the OpenLDAP 2.0 Administration's Guide, have downloaded
the Prerequisits (OpenSSL, SASL, and the BerkeleyDB).

I try to run it on a Linux RedHat 7.0, which was installed as a
workstation, running for the moment as a stand-alone.

I did the following:

1.   I used
          OpenLDAP  openldap-2_0_7.tgz
          TLS       openssl-0_9_6_tar.tar
          SASL      cyrus-sasl-1_5_25_tar.tar
          BerkeleyDB     db-3_2_9_tar.gz.

2.   I packed it out.

3.   For OpenLdap and DB I run "./configure", which ends with
                         Please "make depend" to make dependencies

4.   I build the software (make depend + make) and it takes some

5.   As I try to run the tests, I get the following message "ldap_bind:
Can't contact LDAP server"

What I find very strange is that I managed to contact the server with a
browser, but as an anonymus.

I've read a lot of e-mails describing similar and very similar problems,
I applayed suggested solutions, which worked by others, but not on my
machine. In the /var/log/messages there is the famous IPv6-message

     linux modprobe: modprobe: Can't locate module net-pf-10

But as I manage to get rid of it (with regex from
ftp://ftp.gnu.org/gnu/regex) I don't succed to repare my LDAP.

As I follow the "Admin's Guide"  and nevertheless fail at early stage,
long before I ought to configure the DB and slapd.configure I can't
reffer to the most of the correspodence on the Internet.

Could it be that the RedHat - Installation as a Workstation and not as a
Server makes problems ?

If you can help, describe it in the still " for Dummies", because I'm
quite new in the field.

Please Help