[Date Prev][Date Next] [Chronological] [Thread] [Top]

Security-Authentication??-Invalid Credentials

adding to the previous mail of mine is:

  l searched the directory with

ldapsearch -L  -D"cn=Admin,dc=iperia,dc=com" -b"dc=iperia,dc=com" -u -s sub
'(objectClass=*)' -x -w

iam being prompted for Bind Password:

here iam giving the password which i have assigned to the userpassword
attribute directory entry. iam getting invalid credentials
Bind Password:
ldap_simple_bind_s: Invalid credentials

where iam going wrong??cud anyone help me please...

>  -----Original Message-----
> From: 	Anita Suriarajan  
> Sent:	Wednesday, January 31, 2001 2:00 PM
> To:	Openldap-Software (E-mail)
> Subject:	Security-Authentication??
> Hello,
>    I need to be asked for the password when i try to access the entry in
> the directory, How do i go about it??
>  I have included access control specifier in the slapd.conf file and each
> entry in the directory is having userPassword attribute and what shud i
> need to do, to go furthur??
> slapd.conf:
> access to attrs=userPassword,telephoneNumber
>        by self write
>        by anonymous auth
>        by dn="cn=Admin,dc=iperia,dc=com" write
>        by * none
> access to *
>        by self write
>        by dn="cn=Admin,dc=iperia,dc=com" write
>        by * read
> and each entry is like
> dn: cn=xyz abc,ou=Sales,ou=Employees,dc=iperia,dc=com
> objectClass: Top
> objectClass: organizationalUnit
> objectClass: person
> userPassword: {crypt}xyz
> ou: Sales
> cn: xyz
> sn: abc
	 dn: cn=Admin,dc=iperia,dc=com
	objectclass: person
	objectclass: country
	objectclass: OrganizationalPerson
	userPassword: {crypt}admin
	c: US
	telephoneNumber: 781-993-0001
	cn: Admin
	sn: Anita
> Thanx
> Anita