[Date Prev][Date Next] [Chronological] [Thread] [Top]

PAM User authentication with RedHat 6.2 and openLDAP 2.0.6

Hi everybody,

I've installed nss_ldap-105 module for PAM (RedHat6.2) but it is not
possible to authenticate users against
the openLDAP Directory.

This is my /etc/nsswitch.conf

passwd:     files ldap
shadow:     files ldap
group:      files ldap
ethers:     files
netmasks:   files
networks:   files
protocols:  files ldap
rpc:        files
services:   files ldap

netgroup:   files ldap

This is my /etc/pam.d/login File

auth       required     /lib/security/pam_securetty.so
auth       required     /lib/security/pam_nologin.so
auth       sufficient   /lib/security/pam_ldap.so
auth       required     /lib/security/pam_unix_auth.so try_first_pass
account    sufficient   /lib/security/pam_ldap.so
account    required     /lib/security/pam_unix_acct.so
password   required     /lib/security/pam_cracklib.so
password   required     /lib/security/pam_ldap.so
password   required     /lib/security/pam_pwdb.so use_first_pass
session    required     /lib/security/pam_unix_session.so
session    optional     /lib/security/pam_console.so

This is my /etc/pam.d/passwd
auth       sufficient   /lib/security/pam_ldap.so
auth       required     /lib/security/pam_unix_auth.so use_first_pass
account    sufficient   /lib/security/pam_ldap.so
account    required     /lib/security/pam_unix_acct.so
password   required     /lib/security/pam_cracklib.so retry=3
password   sufficient   /lib/security/pam_ldap.so
password   required     /lib/security/pam_pwdb.so try_first_pass
----snip ----

and this is my /etc/ldap.conf File

# host
# The distinguished name of the search base.
base o=mannesmann,c=de
# Filter to AND with uid=%s
pam_filter objectclass=account
-- snip --- < all other entries are default >

with RedHat Version 7 there is no problem. Where is the mistake? Is There a
Bug? Is there a forgotten entries?

Thanx for your help

with best regards