[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Assistance in compiling OpenLDAP 1.2.6

At 04:33 PM 8/31/99 +1000, Andrew Kemp wrote:
>We currently use OpenLDAP 1.2.3 and today I tried to upgrade to OpenLDAP
>I have installed SleepyCat's DB 2.7.5 under /usr/local/BerkeleyDB/..
>I use the following command line to try and build 1.2.6 :
>env CC=cc CFLAGS=-pthread \
>CPPFLAGS="-I/usr/local/BerkeleyDB/include -I/usr/local/include" \
>LDFLAGS="-L/usr/local/BerkeleyDB/lib -L/usr/local/lib" \
>PATH="/usr/local/bin:$PATH" \
>./configure --enable-dns --enable-wrappers \
>--enable-wrappers --enable-ldbm --with-ldbm-api=db2
>When using the above (and various combinations) I get the following
>checking for DB2 library... checking for db_open in -ldb... no
>checking for db.h... yes
>checking if db.h is DB2... yes
>checking for Berkeley DB2... no
>configure: warning: could not find suitable LDBM backend
>configure: error: select appropriate LDBM options or disable
>Obviously configure is still finding the old DB library shipped with the
>system (Digital Unix 4.0D).

It appears to not to find -ldb in the specified library search path.
You should verify that BerkeleyDB libraries were in fact installed
under /usr/local/BerkeleyDB/lib.  Configure does find db.h and
believes it to be DB2.

>How do I force it to find and use the new 2.7.5 library ?

The command like looks appropriate for forcing use of DB2.
That is, you have the -I and -L flags prepended
to the appropriate environment variables and have selected
the right configure options to require DB2.

The question really is why didn't configure find -ldb in
the search path.  Check config.log.  It should provide an
indicatation as to the exact reason why the configure test
failed to find -ldb.