[Date Prev][Date Next] [Chronological] [Thread] [Top]

Assistance in compiling OpenLDAP 1.2.6


We currently use OpenLDAP 1.2.3 and today I tried to upgrade to OpenLDAP

I have installed SleepyCat's DB 2.7.5 under /usr/local/BerkeleyDB/..

I use the following command line to try and build 1.2.6 :

env CC=cc CFLAGS=-pthread \
CPPFLAGS="-I/usr/local/BerkeleyDB/include -I/usr/local/include" \
LDFLAGS="-L/usr/local/BerkeleyDB/lib -L/usr/local/lib" \
PATH="/usr/local/bin:$PATH" \
./configure --enable-dns --enable-wrappers \
--enable-wrappers --enable-ldbm --with-ldbm-api=db2

When using the above (and various combinations) I get the following

checking for DB2 library... checking for db_open in -ldb... no
checking for db.h... yes
checking if db.h is DB2... yes
checking for Berkeley DB2... no
configure: warning: could not find suitable LDBM backend
configure: error: select appropriate LDBM options or disable

Obviously configure is still finding the old DB library shipped with the
system (Digital Unix 4.0D). How do I force it to find and use the new
2.7.5 library ? Thanks


Andrew Kemp

Unix,WWW,Proxy,News,DNS,LDAP,... Administrator	Phone	: 61 +3 9214-8252
Information Technology Services			Fax	: 61 +3 9214-8944
Swinburne University of Technology		E-Mail: andrew@swin.EDU.AU
Hawthorn, Victoria, Australia 3122 	URL: http://opax.swin.edu.au/andrew