[Date Prev][Date Next] [Chronological] [Thread] [Top]

Kill K&R C support?

As far as I can tell, OpenLDAP has been unusable with K&R C since
openldap-2.0:  lber.h in that release had prototypes unprotected
by LDAP_P() in struct sockbuf_io.  They've been there ever since.
So LDAP_P() can go.

Don't know which other not-strict-ISO support is still useful -
I note lber.h has used <string.h> since openldap-2.2.4, for example.
libldap/open.c has used <limits.h> since 2.0.0.  HEAD wraps that
in HAVE_LIMITS_H, but it does not protect INT_MAX the same way.