[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Check for updatedn (Was: commit: ldap/servers/slapd/overlays rwm.c)

> I think we likely should have:
>         SLAP_SHADOW(bd) - is a shadow database
>         SLAP_SYNC_SHADOW(bd) - is a syncrepl shadow database
>         SLAP_SLURP_SHADOW(bd) - is a slurped shadow database
> and:
>         be_slurp_update(op)
>                 TRUE if SLAP_SLURP_SHADOW and is update DN
>         be_sync_update(op)
>                 TRUE if SLAP_SYNC_SHADOW and is internal sync operation.
> and (if useful):
>         be_shadow_update(op)
>                 TRUE if be_slurp_update() or be_sync_update()

I;m working at this; I also note that there's some namespace
pollution, since the be_*( op ) functions should not be prefixed
be_* any more; maybe op_*( op ) would be more apppropriate.


Pierangelo Masarati