[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: Unable to Connect to Mysql Server by using iODBC Driver Manag er

	Thanks a lot for ur immediate response & help.I tried that & worked but
still I am not able to connect to Mysql Server.

	Now it is giving error message like this :

[iODBC][Driver Manager]Driver's SQLAllocEnv() failed, SQLSTATE=IM004

Its also dumping core.
I also tried strace -s 128 -f -e trace=open ./odbctest, but its giving error ::
ERROR Unable to open /dev/log.

Pl help me out of this.

-----Original Message-----
From: Gilles DAROLD [mailto:gdarold@samse.fr]
Sent: Friday, November 16, 2001 3:50 PM
To: openldap-devel@OpenLDAP.org
Subject: Re: Unable to Connect to Mysql Server by using iODBC Driver


I have experienced the same problem with PostgreSQL and finally
get it work. Don't know if this is the same problem but try this:

When odbctest ask you: 

	Enter ODBC connect string (? shows list):

Type: DSN=OpenLink

If you give only 'OpenLink' you'll get this error SQLSTATE=IM008.
this should be added in the documentation because this is a common

After that if it doesn't work you may have a problem into the odbc.ini
then try to trace what's going wrong with:

strace -s 128 -f -e trace=open ./odbctest


"Chaudhary, Prem Shankar" wrote:
> Hi all,
>         I want to use Mysql as Backend to openldap. I have configured my
> openldap by using --enable-sql.
>         Now in order to connect to the Mysql Server I have Installed ODBC
>         Driver Manager(libiodbbc-3.0.5). But unable to connect to Mysql
>         I have tested by using odbctest program. Its giving error that
>         [iODBC][Driver Manager]Dialog failed, SQLSTATE=IM008
>                                 I have wirtten the iodbc.ini file which is
> this ::
> ;
> ;  odbc.ini
> ;
> [ODBC Data Sources]
> OpenLink = OpenLink (MT)
> [OpenLink]
> Driver          = /u/premc/mysql/lib/mysql/libmysqlclient.so
> Description     = Sample OpenLink MT DSN
> Host            = localhost
> Address             = cs1.hyd.office.juno.com
> Port                = 7000
> ServerType      = Mysql
> FetchBufferSize = 99
> UserName        = root
> Password        = new-password
> Database        = /u/premc/mysql/var/test
> ServerOptions   =
> ConnectOptions  =
> Options         =
> ReadOnly        = yes
> [Default]
> Driver          = /u/premc/mysql/lib/mysql/libmysqlclient.so
>                                 Can anybody help me out of this problem?
>                                 Thanks in advance,
>                                 Prem Shanker Chaudhary

Gilles DAROLD (Service Informatique SAMSE)
e-mail : mailto:gdarold@samse.fr
Tel  : - Fax :