[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: (ITS#7070) test058-syncrepl-asymmetric failed for hdb

michael@stroeder.com wrote:
> Full_Name: Michael Ströder
> Version: HEAD (from git master)
> OS: openSUSE 11.4
> URL: ftp://ftp.openldap.org/incoming/
> Submission from: (NULL) (
>>>>>> Starting test058-syncrepl-asymmetric for hdb...
> running defines.sh
> Initializing master configurations...
> Initializing search configurations...
> Starting central master slapd on TCP/IP port 9011...
> Using ldapsearch to check that central master slapd is running...
> Waiting 1 seconds for slapd to start...
> Waiting 2 seconds for slapd to start...
> Waiting 3 seconds for slapd to start...
> Waiting 4 seconds for slapd to start...
> Waiting 5 seconds for slapd to start...
> ldapsearch failed (255)!
>>>>>> test058-syncrepl-asymmetric failed for hdb
> (exit 255)
> make[2]: *** [hdb-mod] Error 255
> make[2]: Leaving directory `/usr/src/michael/openldap/tests'
> make[1]: *** [test] Error 2
> make[1]: Leaving directory `/usr/src/michael/openldap/tests'
> make: *** [test] Error 2

There's no evidence of an OpenLDAP bug here. All we can see from the 
testrun/slapd.1.log is that it took 15 seconds for slap_sasl_init to complete, 
which was long enough for the initial startup check to time out. You need to 
check your system to see why SASL took so long to initialize, most likely a 
DNS failure or some other transient issue.

Closing this ITS.

   -- Howard Chu
   CTO, Symas Corp.           http://www.symas.com
   Director, Highland Sun     http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP  http://www.openldap.org/project/