[Date Prev][Date Next] [Chronological] [Thread] [Top]

(ITS#6904) correct the recommended backend verbiage in slapd.backends(5)

Full_Name: Tim Mooney
Version: 2.4.25
OS: Linux, Solaris
URL: ftp://ftp.openldap.org/incoming/0001-Update-to-reflect-that-hdb-is-now-preferred-backend.patch
Submission from: (NULL) (2001:4930:106:0:18bb:1140:fa3d:f713)

The slapd.backends(5) man page still indicates that the bdb backend is the
recommended database, even though Quanah has confirmed that for 2.4 and later,
hdb is now preferred, see


I've uploaded a patch to ftp://ftp.openldap.org/incoming against HEAD that
addresses this issue, you can find it as


(Sorry for the name, I'll be more careful to follow the recommended naming
conventions next time).

Note that I used the word "supplanted" rather than "deprecated" in the new
verbiage about bdb, since deprecated seems stronger.  If you would prefer the
term deprecated, let me know and I can upload a new patch with that change.