[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: slapd with wrong url causes "Error detected by libpthread: Invalid mutex"

Jean-Luc Wasmer wrote:

> I didn't make it clear: I was actually asking if this issue was known
> (ie logged somewhere) to avoid polluting the tracking system.

The ITS is seldom "polluted" by issue notifications.

>> This is likely the same as ITS#4957 (already fixed), but it's hard to
>> tell without a proper stack trace (with symbols intact) and without a
>> version number.
> Oh, sorry... I'm using 2.3.32  (but it looks like issue 4957 fix is not
> part of any current release).
> I'll wait 2.3.36 before logging something.

I think this is an unwise attitude.  Submitting issues in old releases
risks to incur into already fixed bugs; but waiting for the next release
to check if an issue disappeared risks to require yet another release to
have it fixed.  Running not yet released code is not really a big deal,
especially if you stick with code tagged for release.  For this purpose,
you need to check out code from the CVS tagged as OPENLDAP_REL_ENG_X_Y
(currently, OPENLDAP_REL_ENG_2_3).  Follow directions at
<http://www.openldap.org/software/repo.html#AnonCVS>.  You'll get
something known to work at least as much as the latest release, plus a
number of known issues fixed.


Ing. Pierangelo Masarati
OpenLDAP Core Team

SysNet s.r.l.
via Dossi, 8 - 27100 Pavia - ITALIA
Office:  +39 02 23998309
Mobile:  +39 333 4963172
Email:   pierangelo.masarati@sys-net.it