[Date Prev][Date Next] [Chronological] [Thread] [Top]

(ITS#3577) back-ldap module broken

Full_Name: Howard Chu
Version: 2.2
OS: x86_64 Linux
URL: ftp://ftp.openldap.org/incoming/
Submission from: (NULL) (
Submitted by: hyc

back-ldap depends on librewrite, which is a static library. When built as a
dynamic module, librewrite must be explicitly linked in to satisfy a variety of
symbol references. Usually libtool complains about the nonportability of mixing
static and dynamic code, but it goes ahead anyway. On x86_64 platforms it just
silently drops the static library from the link step. The resulting back-ldap
module is unusable, there are unresolved references to rewrite_info_init when
you attempt to load it in slapd.

The same issue may affect the rwm overlay in 2.3, although with the
SLAP_AUTH_REWRITE code in place I think all of the necessary symbols will be
present in the slapd binary. Even so, it would probably be best to make
librewrite a shared library.