[Date Prev][Date Next] [Chronological] [Thread] [Top]

naming convention for INTEGER attribute types with measurement unit

Is there a naming convention for attribute types whose SYNTAX is INTEGER?

If I wish to represent 300g as a weight, should I use

  ibmWeightInGrams: 300

  ibmWeightInGRam: 300

  ibmGrams: 300

  ibmGram: 300

What is the convention way? There seems to be no INTEGER attribute types shipped with openldap, thus I have no references.

In my use case, ordered comparison of integer value is required, thus I cannot use:

  ibmWeight: 300g