[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: db_recover gives program version mismatch

On Thu, 20 Dec 2012, anil beniwal wrote:

[root@mmprodam01 data-ldap]# /apps/db4/bin/db_recover -h /apps/openldap/var/openldap-data/
db_recover: Program version 4.7 doesn't match environment version 4.8
I have installed berkely db in /apps/db4  with simple prefix=/apps/db4

What's the output of ldd /apps/db4/bin/db_recover? I'd wonder if it's picking up the wrong shared library. Shouldn't happen, as all of my db_recover binaries link against a soname with the minor in it, but.....