[Date Prev][Date Next] [Chronological] [Thread] [Top]

Migrating 2.4 issue


I try to upgrade openldap to 2.4.

Considering the documentation on my new freshly installed server on which I've restored the slapd.conf of a previous server, I try :

slaptest -f /etc/openldap/slapd.conf -F /etc/openldap/slapd.d

This gives me this issue :

bdb_db_open: database "dc=domain,dc=com": db_open(/var/lib/ldap/id2entry.bdb) failed: No such file or directory (2). backend_startup_one (type=bdb, suffix="dc=domain,dc=com"): bi_db_open failed! (2)

I've found on internet that I can safely ignore this, but it doesn't really work (slapd doesn't want to start correctly after)

How can I fix it ?

Thanks for any help