[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ldap server doesn't run after inserting some groups (cn)

i resolved! the problems were about /var/lib/ldap/* files permissions.
The owner was root. I set owner and group as openldap

chown -R openldap:openldap /var/lib/ldap

and it runs.


On 04/26/2012 08:07 AM, stefano malini wrote:
ok, am sorry.

as said i have LDAP server on Debian Squeeze.
It was working fine until adding this ldif file:

GNU nano 2.2.4 File: /etc/ldap/cn.ldif

#gruppo Studenti
dn: cn=Students,ou=Groups,dc=amahoro,dc=bi
cn: Students
gidNumber: 2000
objectClass: posixGroup

#gruppo Staff
dn: cn=Staff,ou=Groups,dc=amahoro,dc=bi
cn: Staff
gidNumber: 2001
objectClass: posixGroup

#gruppo Admins
dn: cn=Admins,ou=Groups,dc=amahoro,dc=bi
cn: Admins
gidNumber: 2002
objectClass: posixGroup

#gruppo Teachers
dn: cn=Teachers,ou=Groups,dc=amahoro,dc=bi
cn: Teachers
gidNumber: 2003
objectClass: posixGroup

The first time i tried using ldapadd but it gave me this error:

root@amahoro:/etc/ldap# ldapadd -x -W -D 'cn=Manager,dc=amahoro,dc=bi'
-f cn.ldif
Enter LDAP Password:
adding new entry "cn=Students,ou=Groups,dc=amahoro,dc=bi"
ldap_add: Other (e.g., implementation specific) error (80)
additional info: index generation failed

Then i used slapadd without errors:

root@amahoro:/etc/ldap# slapadd -v -f /etc/ldap/slapd.conf -l cn.ldif
hdb_db_open: database "dc=amahoro,dc=bi": unclean shutdown detected;
attempting recovery.
added: "cn=Students,ou=Groups,dc=amahoro,dc=bi" (00000009)
added: "cn=Staff,ou=Groups,dc=amahoro,dc=bi" (0000000a)
added: "cn=Admins,ou=Groups,dc=amahoro,dc=bi" (0000000b)
added: "cn=Teachers,ou=Groups,dc=amahoro,dc=bi" (0000000c)
_#################### 100.00% eta none elapsed none fast!
Closing DB...

 From this moment the ldap server has stopped to work.

This is /var/log/syslog tring to use the server.

Apr 25 19:02:14 amahoro slapd[1463]: hdb_db_open: database
"dc=amahoro,dc=bi" cannot be opened, err 13. Restore from backup!
Apr 25 19:02:14 amahoro slapd[1463]: bdb(dc=amahoro,dc=bi):
txn_checkpoint interface requires an environment configured for the
transaction subsystem
Apr 25 19:02:14 amahoro slapd[1463]: bdb_db_close: database
"dc=amahoro,dc=bi": txn_checkpoint failed: Invalid argument (22).
Apr 25 19:02:14 amahoro slapd[1463]: backend_startup_one (type=hdb,
suffix="dc=amahoro,dc=bi"): bi_db_open failed! (13)
Apr 25 19:02:14 amahoro slapd[1463]: bdb_db_close: database
"dc=amahoro,dc=bi": alock_close failed
Apr 25 19:02:14 amahoro slapd[1463]: slapd stopped.
Apr 25 19:02:34 amahoro nslcd[1085]: [334873] failed to bind to LDAP
server ldap://localhost:389: Can't contact LDAP server: Transport
endpoint is not connected
Apr 25 19:02:34 amahoro nslcd[1085]: [334873] no available LDAP server

The server is connected to the lan but ldap server doesn't work.
What do you think?


On 04/25/2012 08:35 PM, Quanah Gibson-Mount wrote:
--On Wednesday, April 25, 2012 7:22 PM +0200 stefano malini
<lozingalo@gmail.com> wrote:

I had a good LDAP server on Debian Squeeze, everything was ok. I was
to login using ldap users, i was able to make research using ldapsearch.
Now, after adding an ldif file with some groups it doesn't run.

Trying ldapsearch the answer is

ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)

What can be happened?

You don't provide enough information to answer your question.



Quanah Gibson-Mount
Sr. Member of Technical Staff
Zimbra, Inc
A Division of VMware, Inc.
Zimbra :: the leader in open source messaging and collaboration