[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: cannot login using ldap user credential

hi, i make a big mistake and i remove slapd!
am reinstalling it and am finding some troubles doing this.
after configuring slapd id doesn't start. in syslog the error is

<database> failed init (hdb)

follow slapd.conf

include         /etc/ldap/schema/core.schema
include         /etc/ldap/schema/cosine.schema
include         /etc/ldap/schema/inetorgperson.schema
include         /etc/ldap/schema/nis.schema

pidfile         /var/run/slapd/slapd.pid
argsfile        /var/run/slapd/slapd.args
loglevel        trace
modulepath      /usr/lib/ldap
modulepath      back_hdb

#Database Configuration
database        hdb
suffix          "dc=amahoro,dc=bi"
rootdn          "cn=Manager,dc=amahoro,dc=bi"
rootpw          {SSHA}zH2A+jeSlbl2/UcAXm596KPV4IB/R6x9
directory       /var/lib/ldap
index           objectClass,cn  eq

access to attrs=userPassword
        by anonymous auth
        by self write
        by * none

access to *
        by self write
        by * none

what is wrong?

On 04/20/2012 10:05 AM, Arthur de Jong wrote:
On Fri, 2012-04-20 at 08:46 +0200, stefano malini wrote:
please take a look of nslcd debug trying the login using user "zingalo"
that is registered in the ldap server:

nslcd: [3c9869] DEBUG: connection from pid=3209 uid=0 gid=0
nslcd: [3c9869] DEBUG: nslcd_pam_authc("zingalo","","login","***")
nslcd: [3c9869] DEBUG: myldap_search(base="dc=amahoro,dc=bi", filter="(&(objectClass=posixAccount)(uid=zingalo))")
nslcd: [3c9869] DEBUG: ldap_initialize(ldap://
nslcd: [3c9869] DEBUG: ldap_set_rebind_proc()
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_PROTOCOL_VERSION,3)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_DEREF,0)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_TIMELIMIT,0)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_TIMEOUT,0)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_NETWORK_TIMEOUT,0)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_REFERRALS,LDAP_OPT_ON)
nslcd: [3c9869] DEBUG: ldap_set_option(LDAP_OPT_RESTART,LDAP_OPT_ON)
nslcd: [3c9869] DEBUG: ldap_simple_bind_s("uid=nslcd_proc,ou=Users,dc=amahoro,dc=bi","***") (uri="ldap://";)
nslcd: [3c9869] DEBUG: ldap_result(): end of results
nslcd: [3c9869] "zingalo": user not found

what could i check again?

Could you include the output of nslcd when doing
   getent passwd zingalo
Also, does ldapsearch find the user?