[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: modifyTimeStamp not modified on replica

You are right
I modified my syncrepl config to attrs="*,+", then operational attributes are now correctly replicated , thanks !

I also tried to removed attrs directive completly, then the mail attribute wasn't replicated anymore :-( ... so I prefer to let it explicit to

My others openldap 2.3 replica though still have attrs="*" (without the + ), however operational attributes are correctly synchronized, did openldap 2.4 change some defaults about operational attribute replication.

Le 03/04/2012 08:16, Quanah Gibson-Mount a Ãcrit :
You attrs= line is wrong. I suggest you remove it entirely and go with the default value.


On Apr 2, 2012, at 11:11 PM, jehan procaccia<jehan.procaccia@it-sudparis.eu>  wrote:

Le 02/04/2012 20:25, Quanah Gibson-Mount a Ãcrit :
--On Monday, April 02, 2012 5:41 PM +0200 jehan procaccia<jehan.procaccia@it-sudparis.eu>  wrote:

or perhaps an ACL miss-configuration !?
You fail to state what type of replication you are using with OpenLDAP 2.3. Regardless, this would be due to an ACL issue or a misconfiguration of your replication setup.

I use syncrepl replication, either on the openldap 2.3 master and replica which works fine
the same configuration (see below) fails to replicate modifyTimeStamp on a 2.4 replica .

syncrepl        rid=001
                retry="60 10 300 +"
updateref       ldaps://master.int-evry.fr:636

If it's an ACL problem, then would it be on the master side or on the replica's local ACL ?



Quanah Gibson-Mount
Sr. Member of Technical Staff
Zimbra, Inc
A Division of VMware, Inc.
Zimbra ::  the leader in open source messaging and collaboration