[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: groups added to provider not replicating to consumer

--On Monday, April 02, 2012 12:00 AM -0400 btb@bitrate.net wrote:


i've recently set up delta-syncrepl, with one provider and one consumer.
things seemed to be generally working, but i recently noticed that member
attributes in group entries were not getting replicated.  after a bit of
testing, i also found that new groups added to the provider appear to not
be replicated to the consumer.  it also appears that the operation of
adding a group is not being written to the accesslog.  on a possibly
related note, i'm using the memberof overlay, and the memberof attribute
modifications which occur as a result of adding a group are written to
the accesslog, and are replicated to the consumer.  i'm using 2.4.25,
courtesy of ubuntu 11.10.  what can i do to better understand what is
happening, and why?  below is some preliminary data, and log entries
using olcloglevel: any

When you are spending your time using a significantly out of date version of OpenLDAP, and you don't bother to take the time to read the CHANGES file that is publicly available to everyone to see if your issue has already been addressed, you waste everyone's time, but most significantly, your own time. A quick perusal of <http://www.openldap.org/software/release/changes.html> shows specifically that this was fixed in 2.4.26.

OpenLDAP 2.4.26 Release (2011/06/30)
	Fixed slapo-memberof with accesslog (ITS#6329,ITS#6766,ITS#6915)

As usual, using vendor built OpenLDAP packages is generally not recommended. <http://www.openldap.org/faq/data/cache/1456.html>

Also, using Debian/Ubuntu builds that link against GnuTLS are a known security and stability risk.



Quanah Gibson-Mount
Sr. Member of Technical Staff
Zimbra, Inc
A Division of VMware, Inc.
Zimbra ::  the leader in open source messaging and collaboration