[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: smbk5pwd overlay assert/crash


At Fri, 27 Jan 2012 13:32:32 +0100 (CET),
Tiziano Müller wrote:
> I tried to get the smbk5pwd overlay working on SLES11 (openldap 2.4.26).
> Unfortunately the slapd server crashes when I try to change a password as soon
> as the overlay is enabled.
> Running the server either with strace or gdb shows the following as cause for
> the crash:
>   mods.c:64: modify_add_values: Assertion `mod->sm_numvals == i' failed.

It's my fault. Sorry. Please apply the attached patch and retry.

OpenLDAP developers, could you merge this patch to the upstream?

-- Name: SATOH Fumiyasu (fumiyas @ osstech co jp)
-- Business Home: http://www.OSSTech.co.jp/
-- Personal Home: http://www.SFO.jp/blog/

Attachment: openldap-2.4.28-smbk5pwd-fix-shadow-support.patch
Description: Binary data