[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: smbldap-populate error

I have "converted" the new configuration into the old one (/etc/slap/slapd.conf). I saw in a forum that it was possible, so I deleted slap.d directory and placed slapd.conf instead.

Anyway, I had to change the example slapd.conf (/usr/share/slapd/slapd.conf) in order to match the old configuration, which took me quite a while. There are lots of "errors" (or warnings maybe), but I can follow the tutorials (the output of my commands is the same as those on the tutorial), so I suppose that everything is OK

At least the LDAP part is well configured, Now I have to move on to the Windows authentication.

2012/1/4 Simone Piccardi <piccardi@truelite.it>
Il 03/01/2012 19:59, Adrián Arévalo Tirado ha scritto:
> First of all. Thanks for the response.
> I'm totally new to LDAP (so, excuse me if I ask for nonsenses) and, to
> be honest, I don't know which method uses my distro (Debian 6) for
> configuration. On every documentation I see, they use
> /etc/slapd/slapd.conf, but in my case that file doesn't exist.
> Therefore, I'm using /usr/share/slapd/slapd.conf (The only slapd.conf I find).
Recent Debian use the cn=config by default on new installation. You have
to add the samba schema (should be inside the samba-doc package), but I
don't remember if there is an .ldif version or just the old samba.schema

Having a working traditional slapd.conf configuration it's just matter
to add an include for the samba.schema file.