[Date Prev][Date Next] [Chronological] [Thread] [Top]

Not able start TLS.


I have installed openldap from source code on debian squeeze. with following options.

./configure --prefix=/usr/local --enable-slapd --enable-crypt --enable-syslog --enable-wrappers --disable-ipv6 --enable-ppolicy --with-cyrus-sasl --with-threads --with-tls

While trying to start LDAPS,Â
usingÂ/usr/local/libexec/slapd -s 256 -h "ldap:///"

getting following error in the error log.

daemon: TLS not supported (ldaps:///)

I have installed required certificates, ldd output is as follows.

ldd /usr/local/libexec/slapdÂ
linux-vdso.so.1 => Â(0x00007fff1f7ff000)
libdb-4.7.so => /usr/lib/libdb-4.7.so (0x00007f80960b4000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f8095e98000)
libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x00007f8095c7e000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f8095a7a000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x00007f8095843000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00007f809562c000)
libwrap.so.0 => /lib/libwrap.so.0 (0x00007f8095423000)
libc.so.6 => /lib/libc.so.6 (0x00007f80950c2000)
/lib64/ld-linux-x86-64.so.2 (0x00007f8096428000)
libnsl.so.1 => /lib/libnsl.so.1 (0x00007f8094ea9000)

Thanks in advance.

ààààààà àà. àààààà
Meghanand N. Acharekar
" A proud Linux User "
Reg Linux User #397975
The gates in my computer are AND, OR and NOT; they are not Bill..