[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem Compiling openldap-2.4.23

Darouichi, Aziz wrote:
> I installed Berkeley 5.1.25.NC in RHEL 32  when I try to compile
> openldap-2.4.23 using the followings.
> CPPFLAGS="-I/usr/local/Berkely-5.1/include"
> LDFLAGS="-L/usr/local/Berkley-5.1/lib" ./configure  --prefix=/opt/local
> LD_LIBRARY_PATH=/usr/local/Berkley-5.1/lib , export LD_LIBRARY_PATH.
> I get the error message.
> checking for Berkeley DB major version in db.h... 4
> checking for Berkeley DB minor version in db.h... 3
> checking if Berkeley DB version supported by BDB/HDB backends... no
> configure: error: BerkeleyDB version incompatible with BDB/HDB backends

BDB 4.3.x should not be used because of severe issues with this version:


Ciao, Michael.