[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: RHEL 6 OpenLDAP 2.4.19-15.el6 init problem

Hello Markus,
could you please check your file permissions, I think you converted your slapd.conf  file to slapd.d and havn't fixed the permissions, which should be owned to your "ldap" user and group.
That's why it is working with root when you start the daemon manually.

Bye, Benjamin.

On Thu, Mar 31, 2011 at 09:04, Markus Moj <MMoj@timocom.com> wrote:


We are faceing a weird problem with our LDAP running on Red Hat 6.0. When we start our OpenLDAP with the init script as "root" the ldap server starts without problems or errors and seems to be runnig ok. If you connect with an LDAP Browser like Apache Directory Studio and try to edit some parameters in cn=config you get the following error.

[LDAP: error code 80 - internal error (cannot create file)]

But when you start the LDAP server with "/usr/sbin/slapd -h ldap:/// -u ldap" as the init script does, everything is working just fine and you are able to make every change you need to.

Someone out there who has the same problem or already a solution or workaround for this problem?

Mit freundlichen Grüßen / Kind regards
Markus Moj
IT Infrastructure & Services

TimoCom Soft- und Hardware GmbH
In der Steele 2
DE-40599 Düsseldorf
Tel: +49 211 88 26 80 14
Fax: +49 211 88 26 70 14

Geschäftsführer: Jens Thiermann, Gunther Matzaitis
Amtsgericht Düsseldorf, HRB 34489

To be or not to be -- Shakespeare | To do is to be -- Nietzsche | To be is to do -- Sartre | Do be do be do -- Sinatra