[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: slapd 2.2.24 will not start as non root user

Does ldap://XXXXX.XXXXXXXX.XXX have a port >= 1024 at the end ?

If default of 389,  must be root to listen.


On Fri, Feb 25, 2011 at 2:25 AM, Iain M Conochie <iain@shihad.org> wrote:
Good Afternoon,

 I am attempting to upgrade my openldap 2.4.x installation to the latest
release 2.4.24. I am compiling from source. I can start slapd as the
root user but I am unable to start as a non-root user (e.g. ldap). I am
receiving the following error message:

/opt/openldap/libexec/slapd -u ldap -g ldap -h ldap://XXXXX.XXXXXXXX.XXX
slapd: sbind.c:76: ldap_simple_bind: Assertion `(
(ld)->ld_options.ldo_valid == 0x2 )' failed.