[Date Prev][Date Next] [Chronological] [Thread] [Top]

MemberOf attribute not being returned


I'm sure this was working in the past on this server but Im now not getting anything returned when I request the memberOf attribute.

I compiled OpenLDAP 2.4.23 with the following flags:

./configure --prefix=/usr/local/authz --enable-meta --enable-ldap --enable-bdb --enable-monitor --enable-syncprov --enable-translucent --enable-memberof --enable-dyngroup --enable-dynlist --with-threads --with-tls --with-cyrus-sasl --enable-syslog --enable-spasswd cd  make depend make make test make install

I'm using slapd.d and I have the following in /usr/local/authz/etc/openldap/slapd.d/cn=config/olcDatabase={1}bdb


The contents of olcOverlay\=\{1\}memberof.ldif are:

dn: olcOverlay={1}memberof
objectClass: olcOverlayConfig
objectClass: olcMemberOf
olcMemberOfDangling: ignore
olcMemberOfRefInt: FALSE
olcMemberOfGroupOC: posixGroup
olcMemberOfMemberAD: member
olcMemberOfMemberOfAD: memberOf
structuralObjectClass: olcMemberOf
entryUUID: 4d5a3aa8-fbac-45c9-b259-941d13e02724
creatorsName: cn=config
createTimestamp: 20100318151149Z
entryCSN: 20100318151149.488341Z#000000#003#000000
modifiersName: cn=config
modifyTimestamp: 20100318151149Z
olcOverlay: {1}memberof

The log is attached.

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

Attachment: openldap.log
Description: Binary data

Any ideas? The only thing I've changed recently is the ACLs

Kind regards,


Mark Cairney
ITI UNIX Section
Information Services
University of Edinburgh

Tel: 0131 650 6565
Email: mark.cairney@ed.ac.uk