[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ppolicy causing slapcat to segfault

On Friday 15 October 2010 20:45:11 Ryan Steele wrote:
> For reference, this is a slightly older installation (2.4.17 on
> Ubuntu).  I was recently informed that we had to implement the
> ppolicy overlay ASAP for compliance reasons in this environment.  I
> don't have time to upgrade this particular cluster at the moment, so
> I'm trying to work with what I've got.
> The following pastie shows my config (or rather, the LDIFs I used to
> create the config), and a partial trace of the slapcat that
> segfaults: http://pastie.org/1223869
> Interestingly, someone else had an identical issue with 2.4.15 on
> Ubuntu: http://pastie.org/600973
> Unfortunately, no solution was ever posted, and I haven't gotten to
> the bottom of it myself.  I'm not quite sure what the problem is, but
> it seems to be specific to ppolicy, and as far as I can tell by
> reviewing the CVS log for commits to ppolicy.c, no changes have been
> made in any revisions since that would fix a segmentation fault (I'm
> using, and there have been only two unrelated ITS's since
> then as it pertains to ppolicy.c).
> I'm open to suggestions as to what might be causing slapcat to
> segfault after the entries in my pastie above are added. I've tried
> using no default ppolicy, an empty default ppolicy, and with no
> custom pwdCheckModule, all to no avail.

Please try reproducing you problem with the latest release (2.4.23) or 
CVS HEAD. If it still fails with that, open a bug report through the ITS 
(http://www.openldap.org/its) containing the relevant information 
(configs, stack backtrace of the segfault, steps to reproduce, ...).