[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: openldap-2.4.23 compile configure: error: could not locate ndbclient library

--On August 10, 2010 8:16:58 AM +0200 Yusuf Rajah <yusuf@josephking.it> wrote:

Hi All

I have been trying to solve this for 4 days now without any luck. I have
searched and tried fixes and nothing works, I am hoping some fresh minds
and eyes can help me out with this.

I want to run OpenLDAP using MySQL Cluster Server with the ndb backend
database. I have installed mysql-cluster-gpl-7.1.5 from source, it is
working and I have migrated some data into it to test. I am trying to
compile openldap-2.4.23 with support for back-NDB. I run:

./configure --enable-ndb --disable-hdb --disable-bdb

and eventually get:

checking for ndb_init in -lndbclient... no
configure: error: could not locate ndbclient library

Where did you install mysql cluster to? Obviously configure cannot find the ndbclient library. You need to make sure configure can find it by setting LDFLAGS appropriately.


Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration