[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Configuring OpenLDAP on Ubuntu 9.10.Need help!

Thank you Benjamin for your prompt response,
I ve gone through this article you suggested too however the problem here is for entering any command like ldapadd it prompts for entering LDAP password but since dpkg-reconfigure slapd has not asked me to configure any password yet I have no clue what to enter. Do you know of a workaround here?
may be then I could proceed a little  :(

Thanks in advance

On Tue, Mar 30, 2010 at 3:06 PM, Benjamin Griese <der.darude@gmail.com> wrote:
Hi Shamika,

as I read on some community pages, since Ubuntu 9.10 the process of the dpkg scripts has been changed to the basics.
I don't know why this has been done, but that's a matter of fact.
So you have to do some more basic settings on your own via ldif files and ldapadd commands.

You may take a look at this guide: https://help.ubuntu.com/8.10/serverguide/C/openldap-server.html
That guide is still applicable onto newer versions of ubuntu, it even works on a sles11 host.

good look and have fun.

On Tue, Mar 30, 2010 at 11:04, Shamika Joshi <shamika.joshi@gmail.com> wrote:

I have followed following article to install/configure OpenLDAP on Ubuntu Server 9.10

There is no slapd.conf in picture here instead running "dpkg-reconfigure slapd" should come up with following Wizard (got this after running through numerous articles on this)

Wizard steps:

  1. omit openldap server configuration? – no
  2. dns domain name? vm.example.org
  3. organization name? myCompany
  4. database backend to use? hdb
  5. do you want the database to be removed when slapd is purged? yes
  6. may be the question: move old database? yes
  7. administrator password? the same one as entered during installation
  8. confirm password? see last step
  9. allow LDAPv2 protocol? no
However in my installation wizards asks

Omit OpenLDAP server configuration?    No
 Do you want the database to be removed when slapd is purged? No
 Allow LDAPv2 protocol? No
 Creating initial slapd configuration... done.
Starting OpenLDAP: slapd.

Has anyone attempted this before? What I'm missing here? Could someone like to pitch in for some help?

So when I run "ldapsearch -x" it gives me following output

admins@x6:/etc/ldap$ ldapsearch -x
# extended LDIF
# LDAPv3
# base <> (default) with scope subtree
# filter: (objectclass=*)
# requesting: ALL

# search result
search: 2
result: 32 No such object

# numResponses: 1

where is should give the output like
# extended LDIF
# LDAPv3
# base (default) with scope subtree
# filter: (objectclass=*)
# requesting: ALL

# vm.example.org
dn: dc=vm,dc=example,dc=org
objectClass: top
objectClass: dcObject
objectClass: organization
o: myCompany
dc: vm

# admin, vm.example.org
dn: cn=admin,dc=vm,dc=example,dc=org
objectClass: simpleSecurityObject
objectClass: organizationalRole
cn: admin
description: LDAP administrator

# search result
search: 2
result: 0 Success

# numResponses: 3
# numEntries: 2


To be or not to be -- Shakespeare | To do is to be -- Nietzsche | To be is to do -- Sartre | Do be do be do -- Sinatra