[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAP service doesn't start

Emanuele Gesuato wrote:
> We are using OpenLDAP 2.2.29 (the full name of the setup is
> "openldap-2.2.29-db-4.3.29-openssl-0.9.8a-win32_Setup.exe") for a large
> number of Windows 2000 oses with service pack 4.

1. OpenLDAP 2.2.29 is a really ancient release not supported anymore for
quite a while.

2. It is highly recommended *not* to use Berkeley-DB 4.3 with OpenLDAP.

3. OpenSSL 0.9.8a is also outdated and some security fixes have been
added to OpenSSL since then.

4. This seems to be a 3rd-party build.

=> Don't expect anybody to help you with issues deploying this build.

I'd recommend that you should use a more recent versions of OpenLDAP and
all the required software. The OpenLDAP project itself does not publish
binaries. I don't know which Win32 build is currently recommended
though. Maybe others have specific recommendations.

Ciao, Michael.