[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: BDB Inconsistencies when configuring on RH4 vs RH5

--On Friday, February 27, 2009 12:29 PM -0700 Mathew Rowley <mathew_rowley@cable.comcast.com> wrote:

When installing 2.4.11 on my RH4 box, it configures fine with db4-4.2.52

checking for Berkeley DB link (-ldb-4.3)... yes
checking for Berkeley DB version match... yes
checking for Berkeley DB thread support... yes
checking Berkeley DB version for BDB/HDB backends... no
configure: error: BDB/HDB: BerkeleyDB version incompatible
[root@kdc01 openldap-2.4.11]# rpm -qa | grep db4
[root@kdc01 openldap-2.4.11]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.2 (Tikanga)
[root@kdc01 openldap-2.4.11]#

Is this an error in the configure script? Kind of confused. Thanks for any help.

No, this is to help prevent you from going through hell. Don't use BDB 4.3 with OpenLDAP, it's unstable.

I'd also note that BDB 2.4.12+ only support BDB versions 4.4 and later. If you are looking at using OpenLDAP 2.4, I'd strongly advise using OpenLDAP 2.4.15 and a more current release of BDB.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration