[Date Prev][Date Next] [Chronological] [Thread] [Top]

Reentrant library question.

I manage a set of packages under the name pWare for AIX 5.3 and 6.1.

I am upgrading the core OpenLDAP from 2.3.38 to 2.4.11 and wanted to do something IBM does with libc. They link libc.a -> libc_r.a

Is it safe to do the same in OpenLDAP such that:

libldap.so -> libldap_r.so

? Then I rebuild any packages that depended on 2.3 for 2.4.