[Date Prev][Date Next] [Chronological] [Thread] [Top]

Compiling openldap-2.4.8 on cygwin

Has anyone compiled this successfully on cygwin?
I've never compiled anything via this before, but I need 2.4.x for the
memberOf overlay, for which I can't find a windows binary.

My configure string is as follows:
./configure --sysconfdir=/etc/openldap --enable-proxycache
--enable-translucent --enable-bdb --enable-overlays --enable-hdb
--enable-meta --enable-ldap --enable-perl --enable-relay --enable-sql

I get the following error:
cc -g -O2 -o apitest.exe apitest.o  ./.libs/libldap.a
../../libraries/liblutil/liblutil.a /usr/lib/libsasl2.dll.a -lresolv
cannot find -lresolv
collect2: ld returned 1 exit status
make[2]: *** [apitest] Error 1
make[2]: Leaving directory
make[1]: *** [all-common] Error 1
make[1]: Leaving directory `/cygdrive/c/temp/openldap-2.4.8/libraries'
make: *** [all-common] Error 1

Has anyone seen this before?